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Target Finding with SAM and BandMax

This tutorial shows you how to use ENVI’s SAM Target Finder with BandMax wizard to differentiate
planes in an airfield in San Diego, California.

Files Used in This Tutorial

ENVI Resource DVD: Data\aviris\sandiego reflectance.img (and .hdr)

This hyperspectral image is of a naval air station in San Diego, California, collected by the Airborne
Visible/Infrared Imaging Spectrometer (AVIRIS) sensor. The image was atmospherically corrected
using ENVI’s FLAASH module, resulting in a reflectance image.
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Introduction to the SAM Target Finder with
BandMax Wizard

The SAM Target Finder with BandMax wizard guides you through a step-by-step process to find targets
in hyperspectral images using a SAM classification and the BandMax algorithm. The BandMax part of
the wizard increases classification accuracy by determining an optimal subset of bands to help you
separate your targets from known background materials.

The BandMax algorithm was developed by the Galileo Group, Inc. The process is based on the United
States patent application titled Spectral image processing system and method for target detection and
identification.

See the flowchart on Page 2 for a summary of the wizard workflow, which involves six possible steps,
listed below. These steps may occur multiple times in different order, depending upon the your analysis
path:

o Step 1: Select Input Image — Select the input file and the root name of the output files for the
wizard

o Step 2: Select Targets — Select the spectra to use as targets

o Step 3: Select Background — Select backgrounds to suppress

o Step 4: Select Band Subset — Identify significant bands to use in a SAM analysis
o Step 5: Select SAM Parameters — Define a SAM maximum angle parameter

o Step 6: Examine SAM Results — Analyze and examine SAM results. You may exit the wizard
at this time if the results are acceptable

Each step is represented by a panel in the wizard. The Introduction panel (see figure below) explains the
overall workflow of the wizard. The other panels in the wizard present the remaining steps.
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The BandMax Process

Steps 3-4 represent the BandMax process. Step 3 allows you to select the input background spectra. Step
4 displays the BandMax results and enables you to change the parameters of the process to determine an
optimal solution. The results displayed in Step 4 are updated when the parameters are modified.

BandMax rejects background data by determining a subset of spectral image bands that are useful in
distinguishing between target and background spectra. These BandMax significance computations
determine a band significance value for each band. This value is unitless and ranges from 0 to 1. A list
of bands is then derived by comparing the band significance values to the threshold. The resulting band
subset maximizes the contrast between selected target and backgrounds. This subset can then be used as
input to a SAM analysis to reduce processing time and increase accuracy in processing the data by
helping to discriminate targets from background clutter.

Target finding with BandMax is an iterative approach. The SAM analysis on the subset of significant
bands may still produce false positives (data included in a resulting class that do not accurately represent
a target). If examining the results shows that the classification accuracy is not sufficient, the wizard
returns you to Step 2, where you can refine your targets and backgrounds before running BandMax and
the SAM analysis again. You may continue to refine targets, select backgrounds, use BandMax to find
the appropriate band subset, and re-classify your input data with SAM. Moreover, you may need to
adjust the significance threshold in BandMax a few times to obtain an optimal subset for contrasting
targets and backgrounds.

When your analysis is complete, you can save and view a report of the processing. Images resulting
from specific steps in the wizard appear in the Available Bands List. As with any image processing tool,
poor results may occur if you provide poor input data or inappropriate parameters.
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Select Input Data

1. Select File > Open Image File from the ENVI main menu bar. A file selection dialog appears.

2. Navigate to Data\aviris and select sandiego reflectance. img. Click Open. A
color composite is automatically loaded into a display group.

3. Double-click in the Image window to access the Cursor Location/Value dialog. Use this dialog to
browse the image for objects that can be used as possible targets and backgrounds.

& #1 (R:Band 28,G:Band 19,8:Band 10):sandieg... [= |[B][X]
Fossible Targets le Cwerlay Enhance Tools  Window

FPossihle Backgrounds

The image contains several planes. The most noticeable are at pixel locations (232, 136) and (244,
144). However, others appear near pixel locations (89, 11) and (143, 338). In this tutorial, you will
use the SAM Target Finder with BandMax wizard to locate the planes near pixel location (89, 11)
and to differentiate them from those at pixel locations (232, 136) and (244, 144).
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Evaluate Spectra and Start the SAM Target Finder
with BandMax Wizard

1.

From the Display group menu bar, select Tools > Profiles > Z Profile (Spectrum). A Spectral
Profile plot window appears.

From the Spectral Profile menu bar, select Options > Plot Key to display a legend with the
spectrum name.

From the Display group menu bar, select Tools > Pixel Locator. A Pixel Locator dialog appears.
Enter the pixel location (89, 11).

From the Spectral Profile menu bar, select Options > Collect Spectra. This spectrum defines
your target.

In the Pixel Locator dialog, enter the pixel location (244, 144). This spectrum defines a possible
background.

From the Spectral Profile menu bar, select Options and deselect Collect Spectra to stop updating
the Spectral Profile with spectra from the image.

From the ENVI main menu bar, select Spectral > SAM Target Finder with BandMax. The
wizard appears with the Introduction panel.

Click Next to proceed to the Select Input/Output Files panel.
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Interacting With the Wizard

The left part of each panel shows a brief description of the step, requirements of the step, background
information of the process used in the step, and useful analysis techniques for the step. The right part of
the panel contains an interface with specific functions to perform for that step.

You can hide the left part of a panel by clicking Hide Text to only show the right part of the panel. If the
left part is hidden, click Show Text to re-display it. Each panel also contains a Next button for continuing
to the next step and a Prev button for reverting back to the previous step. Next is only enabled if you
provide enough information to continue in the workflow. In some cases, a processing status dialog
appears if the next process is performed before the next panel is initialized.

Unlike other wizards in ENVI, this wizard is not linear. It has conditional paths, where your input may
induce a different direction in the workflow. You can also use the Next and Prev buttons to loop back
through the wizard and repeat a series of steps. The Prev button maintains a list of the steps that were
performed. This list enables the Prev button to still work even if you to go through a conditional step or a
series of steps looping through the wizard.
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Select the Input File

1. This panel represents Step 1 in the workflow. Here, you will specify the input file and the root
name of the output files for the wizard.

2. Click Select Input File. The BandMax Wizard Input File dialog appears.

3. Select sandiego reflectance.img. Click OK. The root name is automatically specified
as the output root name.

4. To specify a different root name, click Select Output Root Name. The Select Output Files Root
Name dialog appears. Specify the root name and path of the output files created throughout the
wizard. If files with the specified root name already exist, you are prompted to allow the wizard
to delete these files and continue. The files will be overwritten. If you do not want to overwrite
the files, click No and specify a different root name in the Select Output Files Root Name dialog.

5. Click Next to proceed to the Target Selection panel.
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Select Targets

This panel represents Step 2 in the workflow. Here, you will collect spectra to be used as targets. The
right part of this panel contains an embedded version of the Endmember Collection dialog (see ENVI
Help for further details).

1. Right-click in the Endmember Spectra table to display a shortcut menu containing the spectra in
the plot key of the Spectral Profile tool. Select Import: X:89 Y:11. The spectrum from (89, 11)
appears in the Endmember Spectra table. This spectrum was collected to represent the target.

2. In the Endmember Spectra Table, select the row number column (on the far left) for the X:89
Y:11 spectrum. To select a spectrum, you must highlight the entire row. You cannot select a
spectrum by clicking its Spectrum Name column.

3. Click Next to proceed to the Background Selection and Rejection panel. All the spectra selected
in the Endmember Spectra table when you click Next are used as targets.

10
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Select Background

1. This panel represents Step 3 in the workflow. Here, you can select as “background” the pixel
spectra that were incorrectly identified as targets in a SAM analysis. The BandMax algorithm
will attempt to identify the bands that are best able to distinguish your targets from these
backgrounds. This process works best when using a small set of target and background spectra.

2. Toggle Select Backgrounds to Reject? to Yes. The Select Background section appears in the
right part of the panel. This section contains the same items as the Target Spectra section in Step
2 of the workflow. If you did not want to specify any backgrounds, you would leave Select
Backgrounds to Reject? set to No. Then, you would click Next to skip to the Select SAM
Mapping Parameters panel, which represents Step 5 in the workflow.

3. Right-click in the Endmember Spectra table and select Import: X:244 Y:144. The spectrum from
(244, 144) appears in the Endmember Spectra table. This spectrum was collected to represent the
background.

4. In the Endmember Spectra Table, select the row number column (on the far left) for the X:244
Y:144 spectrum.

5. Click Next to proceed to the Select Optional Bands panel. All the spectra selected in the
Endmember Spectra table when you click Next are used as backgrounds.

The BandMax algorithm examines your target and background spectra to determine which bands are
most significant for distinguishing your targets from the specified background. The best results are
usually achieved if one target is selected for each wizard session. In this case, BandMax chooses a band
subset that is optimized for that individual target.

11
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Select Band Subset

This panel represents Step 4 in the workflow. Here, you will customize the band subset used to suppress
your backgrounds. The BandMax algorithm calculates a signficance value for each band in the input
image. This unitless value ranges from 0 to 1, where a higher value indicates the band has a higher
probability of distinguishing a target response from a background response. BandMax compares the
significance value to a significance threshold to derive a subset of bands, based upon the current list of
targets and backgrounds.

1.

In the Band Significance Threshold field, enter 0.2775.

The initial threshold (0.2475) was derived to produce a subset containing about 25% of the number
of bands in the entire file. Since sandiego reflectance.img contains 224 bands, the initial threshold
produces 47 significant bands. This number may be too large to accurately differentiate between
targets and backgrounds. Increasing the threshold to 0.2775 produces a smaller number of bands
(32). You can change either the Band Significance Threshold value or the Number of Significant
Bands to determine the optimal band subset for distinguishing between targets and backgrounds. A
higher threshold produces fewer bands.

Click Save Significant Bands to File if you want to save the band subset in the Significant Bands
list to an ASCII file. When you have derived the subset of bands that effectively detects your
targets, you may want to use this same band subset to perform a series of classifications on a set
of images from the same sensor. This output ASCII file can be used as input when spectrally
subsetting a file.

Click Next to proceed to the Select SAM Maximum Angle Threshold panel. The bands in the
Significant Bands list form a band subset that is used as input in the following SAM analysis.

12
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Define SAM Parameters

This panel represents Step 5 in the workflow. Here, you can specify the maximum angle threshold for
the SAM analysis. Decreasing the threshold usually results in fewer matching pixels (better matches to
the reference spectrum). Increasing the threshold may result in a more spatially coherent image;
however, the overall pixel matches will not be as good as for the lower threshold.

1. Inthe SAM Maximum Angle field, enter 0.08 to refine the SAM analysis.
2. Click Next to proceed to the Investigate SAM Results panel.

13



ENVI Tutorial: Target Finding with SAM and BandMax @ENV|

Examine SAM Results

This panel represents Step 6 in the workflow. Here, you can display and examine the results of the SAM
analysis. The output from SAM is a classified image and a set of rule images corresponding to the
spectral angle calculated between each pixel and each target (one rule image per target).

1.

Click Load SAM Class Result. The class image resulting from the SAM analysis appears a new
display group.

Double-click in the Image window of the class image to access the Cursor Location/Value dialog.
As mentioned in the information text for the Investigate SAM Results panel, targets should appear
as spatially coherent classes. The most coherent objects in the resulting class image appear in the
upper-left corner of the image near (52, 33), (70, 22), and (89, 11). Other objects appear in the
class image, but they are not as coherent as the ones in the upper-left corner.

Click Rule (X:89 Y:11) in the SAM Rule Image section, then click Load SAM Rule Image. The
rule image related to the target selected in the SAM Rule Image section replaces the class image
in the display group. A histogram tool and a color table dialog also appear. The plot in the Input
Histogram section of the tool represents the histogram of the rule image. The flat line between
0.000 and 0.095 verifies that the results contain target information. For example, the targets (with
small spectral angles) are well-differentiated from everything else in the scene. Furthermore, the
targets are the brightest objects shown in the rule image.

If the targets had not been differentiated, you would click the Next button to return to Step 2 (see
"Select Targets" on page 10) to refine your targets, backgrounds, or the BandMax process. The
wizard was designed to allow iterations to help you determine the best results. In fact, the Band
Significance Threshold and SAM Maximum Angle values used in this tutorial were actually
derived by iterating through the wizard several times.

Report the Results

1.

Click Show Report in the Investigate SAM Results panel to display the SAM Target Finder with
BandMax Summary Report window. This text report contains the following results for the SAM
Target Finder with BandMax wizard:

o Input file (and any spatial subset) for the wizard

o Specified targets

¢ Specified backgrounds

o Specified band significance threshold

o Resulting significant bands subset

¢ Output files of the SAM analysis

¢ Specified maximum angle parameter for the SAM analysis

From the text window menu bar, select File > Save Text to ASCIL. An Output Report Filename
dialog appears.

Enter the output filename sd_reflectance results.txt and click OK. The text
information in the window is saved to the specified file.

From the text window menu bar, select File > Cancel.

14
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5. Click Finish in the SAM Target Finder with BandMax wizard.
6. Select File > Exit from the ENVI main menu bar.

15
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